Steam Question...

Talk about games or general tech issues that are not Sierra related.
Post Reply
Rath Darkblade
The Cute One
Posts: 4197
Joined: Fri Oct 24, 2008 5:15 am
Location: Lost in Translation
Gender: Male
Contact:

Steam Question...

Post by Rath Darkblade » Mon Nov 17, 2014 2:30 pm

Does anyone know how I can stop Steam from constantly loading up, whenever I turn my computer on? I'm finding that it slows down my computer considerably. I can always load it up later if I need it.

Thanks for your help... :)

User avatar
adeyke
Oldbie
Posts: 792
Joined: Wed Sep 16, 2009 11:47 pm
Location: Germany
Contact:

Re: Steam Question...

Post by adeyke » Mon Nov 17, 2014 3:00 pm

Under the Steam settings, in the Interface tab, there's a "Run Steam when my computer starts" option. Uncheck that.

Rath Darkblade
The Cute One
Posts: 4197
Joined: Fri Oct 24, 2008 5:15 am
Location: Lost in Translation
Gender: Male
Contact:

Re: Steam Question...

Post by Rath Darkblade » Fri Nov 21, 2014 9:12 am

Maybe you have a different version of Steam than I do, adeyke, because I can't see that? *confused*

Here are some vital signs from Steam's Help -> About menu option:

Steam API: v017
Steam packing versions: 1415758987

Does that help?

User avatar
adeyke
Oldbie
Posts: 792
Joined: Wed Sep 16, 2009 11:47 pm
Location: Germany
Contact:

Re: Steam Question...

Post by adeyke » Fri Nov 21, 2014 10:06 am

Your client is slightly out of date (right now, I have Steam package versions 1416350232. Select "Check For Steam Client Updates..." from the Steam menu. It's not a recent change, though, so that shouldn't matter.

I'm puzzled why that option wouldn't be there. Can you post a screenshot of the interface tab?

You could also just go to HKCU\Software\Microsoft\Windows\CurrentVersion\Run in your registry and delete the Steam entry there.

User avatar
Collector
Grand Poobah
Posts: 11080
Joined: Wed Oct 08, 2008 12:57 am
Location: Sierraland
Contact:

Re: Steam Question...

Post by Collector » Fri Nov 21, 2014 11:25 am

Is it possible he could have turned off the update check? Every time that I start it it seems update.
01000010 01111001 01110100 01100101 00100000 01101101 01100101 00100001

Image

User avatar
adeyke
Oldbie
Posts: 792
Joined: Wed Sep 16, 2009 11:47 pm
Location: Germany
Contact:

Re: Steam Question...

Post by adeyke » Fri Nov 21, 2014 1:17 pm

I don't think it's possible to opt out of client updates.

From what I understand, he has the update from November 12, while I have the one from November 19. The change there is a very minor one. Certainly not something as big as adding that checkbox.

User avatar
Collector
Grand Poobah
Posts: 11080
Joined: Wed Oct 08, 2008 12:57 am
Location: Sierraland
Contact:

Re: Steam Question...

Post by Collector » Fri Nov 21, 2014 1:34 pm

If he does not have an always on connection he may have started the client when he had no connection. It would have not been able to update. But will it even load if you are not connected? I have never tried.
01000010 01111001 01110100 01100101 00100000 01101101 01100101 00100001

Image

Rath Darkblade
The Cute One
Posts: 4197
Joined: Fri Oct 24, 2008 5:15 am
Location: Lost in Translation
Gender: Male
Contact:

Re: Steam Question...

Post by Rath Darkblade » Sat Nov 22, 2014 7:00 am

Collector, you're right. I'm not always connected to Steam - in fact, I never connect to Steam unless I have a specific reason to (e.g. play with a friend, or buy a game). Once I've done that, I normally sign off and don't connect again until the next time. ;)

adeyke, I found the option you mentioned and unchecked it. Thanks! :)

Apparently there's a free weekend on "Chivalry: Medieval Warfare". I clicked on it to see what it's about, and apparently it added the game to my library without my knowledge??? :shock: Is it any good? I just don't like games that add themselves to my library and not tell me. (Why ya razzin-frazzin long-eared varmint galoot! </Yosemite Sam> ;) :P

User avatar
adeyke
Oldbie
Posts: 792
Joined: Wed Sep 16, 2009 11:47 pm
Location: Germany
Contact:

Re: Steam Question...

Post by adeyke » Sat Nov 22, 2014 7:27 am

What a free weekend means is that it automatically gets added to everyone's library (and then removed again when the weekend is over). It won't install anything unless you tell it to.

If you don't like seeing it in your library, you could:
  • Not look at your library.
  • Wait until the weekend is over.
  • Set your library to only show installed games (at the top of the list, to the right of the search field, click on GAMES and select Installed).
  • Assign categories to all legitimate games, such that everything in the uncategorized section at the bottom can be safely ignored.
  • Right-click the game in the library, select "Set Categories...", and check the "Hide this game in my library" option (not a good solution, since you'd have to do it to each individual free weekend game, and since this setting would persist even if you actually bought the game; you'd have to then find and undo it for that game).

User avatar
DeadPoolX
DPX the Conqueror!
Posts: 3925
Joined: Mon Oct 27, 2008 3:00 pm
Gender: XY
Location: Canada
Contact:

Re: Steam Question...

Post by DeadPoolX » Sun Nov 23, 2014 7:20 pm

Rath, you have the setting Adeyke was talking about. My laptop's Steam client is older than yours (I usually use my desktop) and it's there, so it's not a client age issue or anything.

Here's how to find it:

1. In the upper left-hand corner of the Steam client, there is a tab labeled "Steam." Click it and you'll see a menu appear below it.

2. The second-to-last option is called "Settings." Click that and a new menu (in a separate window) will appear.

3. There's a tab labeled "Interface" that's sixth down from the top (it's in-between "In-Home Streaming" and "Downloads"). Click that and you'll see a menu with some checkboxes and drop-down menus.

4. The first checkbox will be labeled "Run Steam when my computer starts." Make sure to uncheck it.

Now Steam shouldn't start up automatically when you boot up your computer.

Oh and there is no way to turn off client updates. You can turn off individual game updates, but if a game needs to be updated -- and it's multiplayer -- it'll refuse to run until it's been updated.

I'm not sure how single player games work in this regard. Theoretically they should run just fine with updates switched off, but I don't know for sure because I've never tried it.

As far as Free Weekends are concerned, I distinctly recall Adeyke and I explaining it to you last time this occurred.
Last edited by DeadPoolX on Sun Nov 23, 2014 7:30 pm, edited 1 time in total.
"Er, Tawni, not Tawmni, unless you are doing drag."
-- Collector (commenting on a slight spelling error made by Tawmis)

User avatar
adeyke
Oldbie
Posts: 792
Joined: Wed Sep 16, 2009 11:47 pm
Location: Germany
Contact:

Re: Steam Question...

Post by adeyke » Sun Nov 23, 2014 7:26 pm

Rath had already said that he'd found and unchecked the option.

Even single player games need to be updated in order to launch, assuming Steam knows that there's an update required. If you always run in offline mode, however, you might be able to avoid updating them. I'm always online in Steam, though, and I think auto-updating is a great feature.

User avatar
DeadPoolX
DPX the Conqueror!
Posts: 3925
Joined: Mon Oct 27, 2008 3:00 pm
Gender: XY
Location: Canada
Contact:

Re: Steam Question...

Post by DeadPoolX » Sun Nov 23, 2014 7:32 pm

Must've missed it where he said he found it. Wish I had noticed it before I wrote all that up. :P

Yeah, I like Steam's auto-updating. Sometimes it's a pain when you've got a lot of updates (and in some cases, mods), but it saves you from having to go find each game's individual update yourself.
"Er, Tawni, not Tawmni, unless you are doing drag."
-- Collector (commenting on a slight spelling error made by Tawmis)

Post Reply