Running the demo in DOSBox: too slow

Feeling like you're being haunted? Well, if you look in here, you may find (or at least post for some help!) the answers you're looking for - for the Phantasmagoria games!
Post Reply
Rakeesh
Sierra Obsessed
Posts: 176
Joined: Sun Jul 04, 2010 7:34 am

Running the demo in DOSBox: too slow

Post by Rakeesh » Thu Nov 23, 2017 2:09 pm

I found somewhere in my old files a forgotten zip with files of the Phantasmagoria demo. I unzipped it to a temporary folder, ran the install script from DOSBox etc etc. It seems that the original files are supposed to be in a CD rom so I mounted that folder as a CD rom in DOSBox and attempted to run the demo.

Now, the demo ran very slowly, like a slideshow. I use DB regularly for old games so I was a bit surprised. My explanaton is that the game/demo uses some special DOS drivers or settings (VESA? UniVBE? Still not sure what they stand for) so I must load some drivers or settings in the .conf file, so if you know anything about it pease let me know.

User avatar
Collector
Grand Poobah
Posts: 11105
Joined: Wed Oct 08, 2008 12:57 am
Location: Sierraland
Contact:

Re: Running the demo in DOSBox: too slow

Post by Collector » Fri Nov 24, 2017 9:26 am

01000010 01111001 01110100 01100101 00100000 01101101 01100101 00100001

Image

Rakeesh
Sierra Obsessed
Posts: 176
Joined: Sun Jul 04, 2010 7:34 am

Re: Running the demo in DOSBox: too slow

Post by Rakeesh » Wed Nov 29, 2017 6:02 pm

Thank you Collector but it's not a matter of corrupted files. I have the same problem with running eg. Lighthouse: the intro runs like a slideshow. It's a matter of DOSBox settings.

User avatar
Collector
Grand Poobah
Posts: 11105
Joined: Wed Oct 08, 2008 12:57 am
Location: Sierraland
Contact:

Re: Running the demo in DOSBox: too slow

Post by Collector » Wed Nov 29, 2017 6:49 pm

The demo installer will give you good dosbox.conf and RESOURCE.CFG settings.
01000010 01111001 01110100 01100101 00100000 01101101 01100101 00100001

Image

Rakeesh
Sierra Obsessed
Posts: 176
Joined: Sun Jul 04, 2010 7:34 am

Re: Running the demo in DOSBox: too slow

Post by Rakeesh » Fri Dec 01, 2017 11:09 am

Ok thank you!

Post Reply