Page 1 of 3

My Phantasmagoria playthrough

Posted: Tue Feb 27, 2018 11:26 pm
by notbobsmith
Just started on my playthrough. I ran into a little glitch, however. When I speak to the realtor in the first chapter, the voices cut out intermittently. For example, when I first enter the building, there's no audio. I restore the game, and then the audio is just fine until a little later when the camera changes and it drops out again. I can probably muddle through this, but I was wondering if anyone was aware of this and if there is a fix. I am using the GOG version on DOSBox.

Re: My Phantasmagoria playthrough

Posted: Wed Feb 28, 2018 9:10 am
by Collector
Can you attach a save file from right before entering?

Re: My Phantasmagoria playthrough

Posted: Wed Feb 28, 2018 7:09 pm
by Tawmis
I have the GOG version too - so I can test it for you as well.

Re: My Phantasmagoria playthrough

Posted: Wed Feb 28, 2018 7:32 pm
by notbobsmith
I already moved past that point and the game only keeps a single save file. I *think* it might be because I had the number of cycles too high in DOSBox. I had it at 50k before and then dropped it to 25k and the scene played fine. But then I encountered a similar issue with the dog in front of the house, so it might need some more tweaking. I'll let you know if it continues to be a problem.

Re: My Phantasmagoria playthrough

Posted: Thu Mar 01, 2018 12:39 pm
by Tawmis
notbobsmith wrote:I already moved past that point and the game only keeps a single save file. I *think* it might be because I had the number of cycles too high in DOSBox. I had it at 50k before and then dropped it to 25k and the scene played fine. But then I encountered a similar issue with the dog in front of the house, so it might need some more tweaking. I'll let you know if it continues to be a problem.
The next time it happens - upload the save game - then keep playing. That way we can see if we can replicate it.

Re: My Phantasmagoria playthrough

Posted: Thu Mar 01, 2018 7:11 pm
by Collector
Agreed.

Re: My Phantasmagoria playthrough

Posted: Sun Mar 04, 2018 5:08 pm
by notbobsmith
Been having the same issue every once in a while, but it would only happen once and I couldn't get it to repeat after multiple restores. It happens more consistently in the general store (Chapter 2). I've had the audio drop either after just entering the store, but more often when I talk to the man. I'm using the most recent build of DOSBox-ECE. I've attached my savegame as well as the conf file that I've been using.

Re: My Phantasmagoria playthrough

Posted: Mon Mar 05, 2018 3:27 am
by Qbix
loosing audio ? Mmmm interesting. I have been debugging LSL 7 a lot trying to figure out why it looses audio randomly entering a room. I think it happens less often with a fixed cycle count, but haven't been able to find a cause yet. (even going back to using 0.74 code mixed in with the current code)
Do phantasmagoria and LSL 7 have a similar engine somehow ? (or from the same time maybe ?)

If your savegame is an easy way to trigger it, then that might be a big help as randomly getting it makes for huge log files. LSL 7 is rather stable audio wise with a cycle count of 50-100k.

Re: My Phantasmagoria playthrough

Posted: Mon Mar 05, 2018 8:34 am
by Collector
Is 65535.MAP in the game's base directory or the PATCHES folder? Is 3541.P56 in the base folder?

Re: My Phantasmagoria playthrough

Posted: Mon Mar 05, 2018 6:54 pm
by notbobsmith
Qbix wrote:loosing audio ? Mmmm interesting. I have been debugging LSL 7 a lot trying to figure out why it looses audio randomly entering a room. I think it happens less often with a fixed cycle count, but haven't been able to find a cause yet. (even going back to using 0.74 code mixed in with the current code)
Do phantasmagoria and LSL 7 have a similar engine somehow ? (or from the same time maybe ?)

If your savegame is an easy way to trigger it, then that might be a big help as randomly getting it makes for huge log files. LSL 7 is rather stable audio wise with a cycle count of 50-100k.
That does sound similar to what I am experiencing. It cuts in and out during the conversation with the guy in the store. It only does it when the camera angle changes, which I assume is because they are separate video files. The same problem occurs with the woman in the antique store. Oddly enough, the fairly long cutscene between chapter 1 and 2 runs just fine. I'll try dialing up the number of cycles. It's worth noting that the conf file that GOG provides sets it to max. I try to avoid that since I always get this popping noise in the audio whenever it is set to max.
Collector wrote:Is 65535.MAP in the game's base directory or the PATCHES folder? Is 3541.P56 in the base folder?
65535.MAP is in PATCHES and 3541.P56 is in the base folder.

Re: My Phantasmagoria playthrough

Posted: Mon Mar 05, 2018 7:13 pm
by Collector
Qbix wrote:Do phantasmagoria and LSL 7 have a similar engine somehow ? (or from the same time maybe ?)
Phantasmagoria is SCI2.1 and LSL7 is SCI3.

Re: My Phantasmagoria playthrough

Posted: Tue Mar 06, 2018 12:13 am
by notbobsmith
So I ended up setting cycles to max in DOSBox and that seems to at least mitigate the issue. Before the sound would drop out almost every other scene in a conversation. Now I can sometimes make it through without it dropping out at all, though it still crops up every once in a while. I also don't get the audio popping that I've experienced in the past with setting the cycles to max.

Re: My Phantasmagoria playthrough

Posted: Tue Mar 06, 2018 3:39 am
by Qbix
notbobsmith wrote: I also don't get the audio popping that I've experienced in the past with setting the cycles to max.
Yeah, I fixed/improved that with the help of BBP and others a while ago. It seemed to happen exclusively on windows 7. So I guess you are on that.

I noticed that you have prebuffer at 20, I have changed the default value to 25

Could you for the sake of trying, set the cycles to 75000 ? As that is the value that makes LSL 7 the happiest at my place with the current code.
Still trying to figure out what is going wrong with the sierra games..

Re: My Phantasmagoria playthrough

Posted: Tue Mar 06, 2018 8:39 am
by Collector
There is also the audio crackling in RAMA.

Re: My Phantasmagoria playthrough

Posted: Tue Mar 06, 2018 9:45 pm
by notbobsmith
Qbix wrote:
notbobsmith wrote: I also don't get the audio popping that I've experienced in the past with setting the cycles to max.
Yeah, I fixed/improved that with the help of BBP and others a while ago. It seemed to happen exclusively on windows 7. So I guess you are on that.

I noticed that you have prebuffer at 20, I have changed the default value to 25

Could you for the sake of trying, set the cycles to 75000 ? As that is the value that makes LSL 7 the happiest at my place with the current code.
Still trying to figure out what is going wrong with the sierra games..
I changed prebuffer to 25 and set the cycles to 75000 but still have the problem. I increased the cycles to max and had almost the same result. The general store seems to be especially problematic. Increasing the cycles to max seemed to have helped in the antique store.
Collector wrote:There is also the audio crackling in RAMA.
Not to pile things on anymore, but there also seem to be some popping in the dialogue in Gabriel Knight.