Got it working Win x64 (8.1) with gamepad - here's tips

Before there was Pacific Rim, there was Metaltech! Enter the Earthseige! Enter the Battledome! Enter this section of the forum for any comments, questions or problems with any of the Metaltech games!
Post Reply
Posts: 1
Joined: Wed Jun 21, 2017 5:11 am
Gender: Not Specified

Got it working Win x64 (8.1) with gamepad - here's tips

Post by Wayfarer » Fri Jun 23, 2017 4:01 am

Hey! A few times over the years I've tried to play ES2 again but without any joy. So I was pretty stoked to see the installer Collector had made. Thanks heaps for doing that, and for maintaining it, too :D

Also, that Hi-Rez released ISOs is very cool. I grabbed it for convenience, and at first I thought it was gonna help new system matters, even though I've still got my old disc somewheres.

I had to garner a few bits and pieces from several places, but in the end got a pretty good result. So I thought to post in one place here, ya never know maybe it'll help someone else out.

One thing though - has anyone got a reliable fullscreen / upscaled display going?? I can make it fullscreen but then the cursor and buttons don't line up. Fullscreen with dgVoodoo2 isn't very successful, either. So gotta play on a sad-looking teeny window, even if I put desktop resolution to lowest at 1024x748. But it plays! And that's cool.

• More-or-less, just using the installer by Collector did the trick.
- At first I had a ddraw error and a blank white screen on startup, and the closing Explorer was awkward to recover from.
- User Expack3 had mentioned the same, and a resolution, using dgVoodoo2:
Expack3 wrote:Of course, now there's another problem: I keep getting the following error in the file assert.log:

Code: Select all

Assert::err: Line 842 in "src\winstuff.cpp": coulnd't create dd surface.
As such, because I have a DirectX 10.1-compliant GPU, I was able to use the Direct3D/DirectDraw 1-7 portion of the dgVoodoo2 graphics API wrapper. Not only does the game run without the error when using the wrapper, it no longer needs explorer.exe shut down while the application is running. Despite dgVoodoo2 handling 256-color palette operations just fine, I get the "you are not in 256 color mode" message.

That said, I do realize dgVoodoo2 is likely beyond the system requirements you're aiming for; I only brought it up because it's an actively-developed solution I use which has worked in the past extremely well, and happens to work here.
- I recommend downloading dgVoodoo2, drop the dlls from the MS folder into your ES2 folder.

• There's a thread about the Hi-Rez ISO, and nope - it doesn't contain the music files. But the installer can, and will download the MP3s (it's awesome). I had some troubles at first, and again, others had the same and a fix :)
- When it's on "extracting audio track", it might get stuck, you might have to open up Task Manager and kill the process "cdda2wav". Then it sorts itself out.
- I also needed to install _inmm, downloaded it from this post by Collector.
zeether wrote:I'm experiencing the same error with the ES2 installer where it freezes at "extracting audio track 2" but whenever I clear the cache in my browser and attempt to redownload it keeps throwing up "connection reset" errors or the installer just won't download and give me network errors.

Edit: I found out that I had to stop the cdda2wav process in task manager to get it to work. It asked if I wanted to download the music.
• Controls... I used to play this back in the day with a Sidewinder. These days, I don't have a joystick. I tried using the keys but eeeehhh.... If you don't have a joystick, but you do have a gamepad, you can try this - assuming your gamepad isn't recognised by ES2:
- Download UCR, Universal Control Mapper, lets you bind a bunch of inputs to a bunch of outputs.
- I tried using vJoy, a very cool virtual device driver emulator, but ES2 didn't recognise it.
- I set up my PS4 controller with DS4Windows and, since I couldn't map to axes, instead mapped the sticks to the keyboard controls.
It works pretty well; though diagonal turret movement is flaky.

So yeah, woowoo Earthsiege 2(017)!!!

User avatar
Grand Poobah
Posts: 11485
Joined: Wed Oct 08, 2008 12:57 am
Location: Sierraland

Re: Got it working Win x64 (8.1) with gamepad - here's tips

Post by Collector » Fri Jun 23, 2017 8:48 pm

Thanks for letting us know How you tweaked it.
01000010 01111001 01110100 01100101 00100000 01101101 01100101 00100001


Post Reply